$re = '/(\s*(\r\n?|\n)){3,}/m';
$str = 'a
xsdasda
xsdasd
xsdasd
xsdasda';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);