$re = '/^[a-zA-Z0-9 !@#$%^&*)(]{2,20}$/';
$str = '01 - 1104
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);