// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)([\x{0410}-\x{042F}\x{0406}\x{0407}\x{0404}][\x{0430}-\x{044F}\x{0456}\x{0457}\x{0454}\x{0401}\s\.]+)").unwrap();
let string = "2 кімн кв П Мирного 6300(Євроремонт, спальня+кухня-студіо, інтернет, посуд, пральна машинка-автомат, плазмовий новий телевізор, нова вся побтуова техніка, вмонтовані нові меблі Командор, шафи-купе, Автономне опалення(2 функційний котел)ТЕЛ:0980073077, 0633002215 Яна
1 кімн кв Кирила і Мефодія 4000( не великої площі, для 1 особи, ТВ, інтернет, КТБ, євроремонт, нова душова кабінка, бойлер, своє опалення, квартира повністю умебльована, пральна машинка, холодильник, телевізор, співпрацюю! Терміново! суттєві знижки на маклерські послуги!!!)ТЕЛ: 0679045723, 0931324895 Максим
2 кімн. вул Глібова 4500 грн Гарний житловий стан, кухня і ванна після ремонту, індивідуальне опалення, вся побутова техніка, умебльована, інтернет. вільна. на+ ТЕЛ: 0987113577, 0734192485 Олексій
1 кімн кв Кирила і Мефодія 4000( не великої площі, для 1 особи, ТВ, інтернет, КТБ, євроремонт, нова душова кабінка, бойлер, своє опалення, квартира повністю умебльована, пральна машинка, холодильник, телевізор, співпрацюю! Терміново! суттєві знижки на маклерські послуги!!!)ТЕЛ: 0679045723, 0931324895 Максим";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}