# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^(?=(?:(?!\r?\n\r?\n)[\s\S])*\bNew-York\b)(?=(?:(?!\r?\n\r?\n)[\s\S])*\bBerlin\b)[\s\S]*?(?:\n\n|\Z)"
test_str = ("This is paragraph #1\n"
"New-York, London, Paris, Berlin\n"
"Some other text\n"
"End of paragraph\n\n"
"This is paragraph #2\n"
"London, Paris\n"
"End of paragraph\n\n"
"This is paragraph #3\n"
"New-York, Paris, Berlin\n"
"Some other text\n"
"End of paragraph\n\n"
"This is paragraph #4\n"
"End of paragraph\n\n"
"This is paragraph #5\n"
"Paris, Berlin\n"
"Some other text\n"
"End of paragraph")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.