const regex = /[-\d]+(?=[;,. ])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[-\\d]+(?=[;,. ])', 'g')
const str = `K9908098F, G2342D34324/ 234234323, 234-234-234; R324234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}