package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Star)`)
var str = `Start to End
Start to End`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}