# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([a-z0-9_-]+)(\.[a-z0-9_-]+)?@([a-z0-9_-]+)\.([a-z0-9]{2,})$"
test_str = ("<header class=\"noSelect\">\n"
" <div id=\"HIAccueil\" class=\"I-B\">\n"
" <img class=\"pointer\" src=\"IMG/BACKGROUND/HEADER/logoban.png\" alt=\"Accueil\" onclick=\"clickMenu(tousLesMenus, 2, tousLesMenus[0].nom, 1, 0, 0, 0, tousLesMenus[1].url);\">\n"
" </div>\n"
" <div id=\"HIPC\">\n"
" <div id=\"HIProfile\" class=\"I-B\">\n"
" <!-- vide pour img via js -->\n"
" </div>\n"
" <div id=\"HIConnect\" class=\"I-B\">\n"
" <img class=\"pointer\" src=\"IMG/BACKGROUND/HEADER/connect_hover.gif\" alt=\"Connect\" onclick=\"clickMenu(tousLesMenus, 5, tousLesMenus[0].nom, 4, 1, 1, 0, tousLesMenus[4].url);\">\n"
" </div>\n"
" </div>\n"
"</header>\n"
"Tralloc_Nivek-02.baza_R-d421@gmail45.com\n"
"Tralloc_Nivek-02@gmail45.com\n"
"Tralloc_Nivek-02.baza_R-d421gmail45.c\n\n"
"010/226679\n"
"010226679\n"
"010/22.66.79\n"
"010/22 66 79\n"
"0470040747\n"
"0470/040747\n"
"0470/040.747\n"
"0470/04.07.47\n"
"0470/04 07 47\n"
"0470/040 747\n"
"+0032470040747\n"
"0032470/040 747\n"
"+00320470040747")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.