$re = '/^(.*?)(\w{3} \d{1,2}, \d{4} \d{2}:\d{2}:\d{2} PDT)(.*?)$/m';
$str = 'one, Aug 21, 2018 11:08:51 PDT, last
two, newlast, Aug 22, 2018 11:08:52 PDT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);