use strict;
my $str = 'This is some text with a Hello World in it';
my $regex = qr/Hello\sWorld/mp;
my $subst = 'Hello World\\Earth';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";