package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^S\d+Q\d+`)
var str = `1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}