$re = '/^\b(?!.*?\s{2})[A-Za-z ]{1,50}\b$/';
$str = 'Hello this is an example';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);