package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)([\x{201C}])`)
var str = `Test “,â€," Data`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}