$re = '/^(?:[\+-]?\d{4}(?!\d{2}\b))(?:(-?)(?:(?:0[1-9]|1[0-2])(?:\1(?:[12]\d|0[1-9]|3[01]))?|W(?:[0-4]\d|5[0-2])(?:-?[1-7])?|(?:00[1-9]|0[1-9]\d|[12]\d{2}|3(?:[0-5]\d|6[1-6])))(?:[T\s](?:(?:(?:[01]\d|2[0-3])(?:(:?)[0-5]\d)?|24\:?00)(?:[\.,]\d+(?!:))?)?(?:\2[0-5]\d(?:[\.,]\d+)?)?(?:[zZ]|(?:[\+-])(?:[01]\d|2[0-3]):?(?:[0-5]\d)?)?)?)?$/m';
$str = '2021
2021-10
2021-00
2021-13
2021-10-24
2021-10-00
2021-10-32
2021-10-24T10
2021-10-24T48
2021-10-24T10:30
2021-10-24T10:95
2021-10-24T10:30:47
2021-10-24T10:30:78
2021-10-24T10:30:47.5
2021-10-24T10:30:47.333
2021-10-24T10:30:47.333333
2021-10-24T10:30:47Z
2021-10-24T10:30:78Z
2021-10-24T10:30:47.5Z
2021-10-24T10:30:47.333Z
2021-10-24T10:30:47.333333Z
2021-10-24T10:30:47-03:00
2021-10-24T10:30:78-03:00
2021-10-24T10:30:47.5-03:00
2021-10-24T10:30:47.333-03:00
2021-10-24T10:30:47.333333-03:00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);