#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Leading\s+\K\w+"
Local $sString = "Leading Men (Average American male: 5 feet 9.5 inches)" & @CRLF & _
"" & @CRLF & _
"Dolph Lundgren — 6 feet 5 inches" & @CRLF & _
"John Cleese — 6 feet 5 inches" & @CRLF & _
"" & @CRLF & _
"Leading Ladies (Average American female: 5 feet 4 inches)" & @CRLF & _
"" & @CRLF & _
"Uma Thurman — 6 feet 0 inches" & @CRLF & _
"Brooke Shields — 6 feet 0 inches"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")