#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)http:\/\/mywebsite\.com\/\K[a-zA-Z]+$"
Local $sString = "http://mywebsite.com/1234" & @CRLF & _
"http://mywebsite.com/foo" & @CRLF & _
"http://mywebsite.com/bar" & @CRLF & _
"http://google.com" & @CRLF & _
"http://mywebsite.com/bar6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")