using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[.*\]\((?:https://)(?:media|cdn)(?:\.discordapp\.)(?:net|com)(?:/(?:attachments|emojis|stickers)/.*\)))?(\[.*\]|[^\[]*)(?:\[.*\]\((?:https://)(?:media|cdn)(?:\.discordapp\.)(?:net|com)(?:/(?:attachments|emojis|stickers)/.*\)))?";
string input = @"[k9_et_PAT](https://cdn.discordapp.com/emojis/1290159554080018432.gif?size=48&animated=true&name=k9_et_PAT)
[RoloHeadpat](https://media.discordapp.net/stickers/1331814642959515699.png?size=160&name=RoloHeadpat)
[funny_meme](https://cdn.discordapp.com/attachments/408346996823556097/1357753754514100364/NO-WAY-1743754818196.png?ex=67f2abb8&is=67f15a38&hm=2481a2440e02712ff422d605416d1395c973144e51d2e882e7615fbd15a53372&)
[totally_malicious](google.com)
a[k9_et_PAT](https://cdn.discordapp.com/emojis/1290159554080018432.gif?size=48&animated=true&name=k9_et_PAT)
a[RoloHeadpat](https://media.discordapp.net/stickers/1331814642959515699.png?size=160&name=RoloHeadpat)
a[funny_meme](https://cdn.discordapp.com/attachments/408346996823556097/1357753754514100364/NO-WAY-1743754818196.png?ex=67f2abb8&is=67f15a38&hm=2481a2440e02712ff422d605416d1395c973144e51d2e882e7615fbd15a53372&)
a[totally_malicious](google.com)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}