using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\""|\')(?<key>[\w\d]+)(?:\""|\')(?:\:\s*)(?:\""|\')(?<value>[\w\[\]]*)(?:\""|\')";
string input = @"{""employees"":[
{""firstName"":""John"", ""lastName"":""Doe""},
{""firstName"":""Anna"", ""lastName"":""Smith""},
{""firstName"":""Peter"", ""lastName"":""Jones""}
]}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}