import re
regex = re.compile(r"\[[^\[]*[^\]]*\]", flags=re.IGNORECASE)
test_str = ("[products-tab collection=\"frontpage,new,all-1\" title=\"BEST SELLING\" nav=\"true\" style=\"product-loop-swatch\" rows=\"2\" items=\"8\" header=\"style-1\"]\n\n"
"[products-deal product=\"apple-iphone-se,armani-exchange-brown-leather-watch-ax2181\" title=\"DEAL OF THE DAY\"]\n\n"
"[blog blog=\"news\" desc=\"If you are interested in the latest articles in the industry, take a sneak peek at our blog. You’ve got nothing to loose!\" style=\"style-2\"]\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")