re = /hello\s*(.*?)\s*(?=hello|\z)/mi
str = 'hello i am xyz lol hello i
am abc ..;sda<>
hello
i am pqr ahe kiop hello
abc axyz
no
yes
hepdd
jol
hello
podjkd
dasfh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end