$re = '/^(?=\D*\d)(?=[^A-Z]*[A-Z])[a-zA-Z]/m';
$str = 'aB7
a7B
A%9
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);