$re = '/^(?:\w+|\w+([+\.-]?\w+)*@\w+([\.-]?\w+)*(\.[a-zA-z]{2,4})+)$/m';
$str = 'totoprayogo1916
totoprayogo1916@gmail.com
totoprayogo1916+mail@gmail.com
mail@totoprayogo.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);