import Foundation
let pattern = ##"[a-z](?:[a-z]|\d|[+-.])*:(?:\/\/(?:(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|:)*@)?(?:\[(?:(?:[0-9a-f]{1,4}:){6}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|::(?:[0-9a-f]{1,4}:){5}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){4}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:)?[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){3}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,2}[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){2}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,3}[0-9a-f]{1,4})?::[0-9a-f]{1,4}:(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,4}[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,5}[0-9a-f]{1,4})?::[0-9a-f]{1,4}|(?:(?:[0-9a-f]{1,4}:){0,6}[0-9a-f]{1,4})?::|v(?:[0-9a-f])+\.(?:[a-z]|\d|[-._~]|[!$&'()*+,;=]|:)+)]|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)|(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=])*)(?::(?:\d)*)?(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*|\/(?:(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]){1,}(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*)?|(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]){1,}(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*|)(?:\?(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]|[/?])*)?(?:#(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]|[/?])*)?|(?:\/\/(?:(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|:)*@)?(?:\[(?:(?:[0-9a-f]{1,4}:){6}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|::(?:[0-9a-f]{1,4}:){5}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){4}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:)?[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){3}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,2}[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){2}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,3}[0-9a-f]{1,4})?::[0-9a-f]{1,4}:(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,4}[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,5}[0-9a-f]{1,4})?::[0-9a-f]{1,4}|(?:(?:[0-9a-f]{1,4}:){0,6}[0-9a-f]{1,4})?::|v(?:[0-9a-f])+\.(?:[a-z]|\d|[-._~]|[!$&'()*+,;=]|:)+)]|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)|(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=])*)(?::(?:\d)*)?(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*|\/(?:(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]){1,}(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*)?|(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|@){1,}(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*|)(?:\?(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]|[/?])*)?(?:#(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]|[/?])*)?"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"local://[A:A:A:A:A:A::AFCE]//kill/0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}