re = /'([^\\']|(?:\\.))*'/m
str = 'It was \'He said \\\'hello\\\' to her\' not the other way around.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end