re = /\b[A-Z]{2}\b/m
str = 'EFS Web 2.1.17
Corresponding to
1 102742238 CN A 2012-10-17 ZTE USA Inc. US20130094411A1
3 20150318972 2015-11-05 Zhang et al.
2 20130128860 2013-05-23 Zhang
1 20130094411 2013-04-18 Zhang
EFS Web 2.1.17
Examiner Signature Date Considered
3rd Generation Partnership Project; Technical Specification Group Radio Access Network; Evolved Universal
1 Terrestrial Radio Access (E-UTRA); Physical channels and modulation (Release 12), 3GPP TS 36.211 V12.7.0
fONAR_ NAN 12R nanac
vs Corresponding to
4 2014110837 WO Al 2014-07-24 Fujitsu Ltd. et al. US20150318972A1
3 2014107012 WO Al 2014-07-10 LG Electronics Inc.
; Corresponding to
2 103120006 CN A 2013-05-22 ZTE Corporation US20130128860A1 A fg FG ddDF dFGg A1 AL Al
EFS Web 2.1.17
| |
pore !'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end