$re = '/(?i)^\d+\syears?\sold/m';
$str = '1 year old\',
14 years old\',
music store\',
7 years old \',
16 years old \',';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);