#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,2}(?:\.\d{1,2})?$"
Local $sString = "Valid:" & @CRLF & _
"1.1" & @CRLF & _
"11.1" & @CRLF & _
"1.11" & @CRLF & _
"11.11" & @CRLF & _
"2" & @CRLF & _
"22" & @CRLF & _
"" & @CRLF & _
"What should be invalid:" & @CRLF & _
"111.111" & @CRLF & _
"222"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")