package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9][0-9]|[0-9]X)+`)
var str = `12345678
12345X78
1X3X5X7X
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}