$re = '/^(\(\d+,\s*.*?(\d+).*?value":).*?([,}])/m';
$str = '(602, \'0602\', \'[{"id":"9","value":""},{"id":"1","value":"1"}]\'),
(1644, \'0164\', \'[{"id":"9","value":""},{"id":"1","value":"3"}]\'),
(1311, \'0131\', \'[{"id":"9","value":""},{"id":"1","value":"100"}]\'),
(1321, \'0132\', \'[{"id":"9","value":""},{"id":"1","value":"150"}]\')';
$subst = "\1\2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;