import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*?<\\/a>";
final String string = "<a>sfsdfsdfsdf</a>\n\n\n"
+ "sfsfas\n\n"
+ "f\n\n"
+ "<a>\n"
+ "asfsafsa\n\n"
+ "s</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}