use strict;
my $str = 'H-4WEH52HE5X/10CW110N9S2K4
H-4WEH52E5XF/10CG205N9K4
H-4WH52G5X/S2
H-4WEH52D5X/10LG24NS2Z5L/B15SO260
H-4WEH52J5X/10LG24NS
H-4WEH52L5X/10LG24NSZ5L
H-4WEH52C5XF/10LG24NSZ5L
H-4WEH52E5X/10AW220NS2Z5L
H-4WEH52E5X/10LG24NZ42
H-4WEH52E5XF/10AG24N
H-4WEH52D5X/10LG24NS2Z5L/10B15SO440
H-4WEH52D5X/10LG48NS2Z5/10B15SO260
H-4WEH52D5X/10LG24NS2Z5L/10B15SO260
H-4WEH52J5X/10LG24NS2Z5L/10
H-4WEH52H5XF/10AW220NDL
H-4WH52HU5X/S
H-4WEH52G5X/10LG24NZ4/13
H-4WEH52E5X/10AG24N/B10
H-4WEH52J5X/10AG24NS2
H-4WEH52E5X/10AW110NDL/D1
H-4WEH52G5X/10AG24ND
H-4WEH52E5X/10AG220NS/B10SO321
H-4WEH52J5X/10LG24NS2Z4
H-4WEH52J5XF/10AG24NZ4
H-4WEH52E5X/10AW240NS/B12SO321
H-4WEH52H5XF/10AW110NDL
H-4WEH52H5X/10AG42NS2D/B08SO561
H-4WEH52G5X/10AG42NS2D/B08SO561
H-4WEH52E5XF/10LG24NSZ5L
H-4WEH52E5X/10AG24NZ4
H-4WH52C5X/
H-4WEH52S5XF/10AG24NSZ4/22
H-4WEH52E5X/10LW220-50NS2Z4
H-4WEH52C5XF/10LG24NSDZSO387
H-4WEH52E5XF/10AG24NSZ5L
H-4WEH52G5XF/10AW220NS2Z5L
H-4WEH52J5XF/10AG24N/B12
H-4WEH52J5X/10AG24NZ4
H-4WEH52H5X/U
H-4WEH52H5XF/U
H-4WEH52T5XF/10LW110-60NZ4
H-4WEH52D5X/10LG24NDZ
H-4WEH52G5X/10AW110NS2Z5L
H-4WEH52E5X/10LW220-50NSZ4
H-4WEH52D5XF/10LW220-50NSO388
H-4WH52J5X/
H-4WEH52GB5X/10AG24NZ5L
H-4WEH52T5X/10LW110-60NZ4
H-4WEH52D5XF/10LW48-50N
H-4WEH52H5X/10AW220NZ5
H-4WEH52D5XF/10AG24NZ5L
H-4WEH52L5X/10AW110NSZ4
H-4WEH52D5X/10AG24NS2Z5L
H-4WEH52J5X/10AW110NZ4
H-4WEH52D5X/10LG24NS2
H-4WEH52HE5X/10AG24NSSO221
H-4WEH52D5X/10LW120-60NS2DZL
H-4WEH52E5X/10AW110NSDL
H-4WEH52E5X/10AW240NSO321
H-4WEH52E5X/10AW110NETSDL
';
my $regex = qr/^(?P<operating_pressure>H)(?P<sep_1>-)(?P<number_of_main_ports>4)(?P<unit_type>W)(?P<actuation_type>EH|H)(?P<unit_size>52)(?P<spool_feedback_main_stage>H|)(?P<spool_symbol>C|D|K|Z|E|F|G|H|J|L|M|Q|R|S|T|U|V|W)(?P<unit_series>5X)(?P<mounting_type>F|)(?P<sep_2>/)(?P<spool_feedback>OF|O)(?P<pilot_valve>10)(?P<type_of_solenoid>A|L)(?P<solenoid_in_ac_or_dc_version>G|W)(?P<voltage_of_solenoid>220|195|180|127|120|110|96|60|42|24|12)(?P<voltage_rectifier>R|-|)(?P<frequency_of_ac_voltage>60|50|)(?P<manual_override_unit>Y|)(?P<unit_for_time_adjustment>S2|S|)(?P<electrical_connection>Z5L|Z2L|Z1L|DKL|DZL|DL|DZ|DK|ZL|KL|Z5|Z4|Z2|Z1|K4|D|L|Z|K)(?P<sep_3>/)(?P<additional_equipment>25|24|23|22|21|20|19|18|)(?P<orifice_positon>B|)(?P<orifice_diameter>15|12|11|10|08|)(?P<seal_material>V|)(?P<additional_details>)$
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}