package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z]|0-9`)
var str = `abz
a
b
c
d
1
0-9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}