$re = '/\w+$/m';
$str = '*A* abcd efgh ijkl Word
djdjfjfjfjfjfkfkfkfk agjfj
gjfjfjfjfkfkffk sjfjfj
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);