#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\w+)\s(.+)\s(\w+)$"
Local $sString = "Kaiya Devine Rahman" & @CRLF & _
"Zunairah Field Cairns" & @CRLF & _
"Oliwia Ramos Smith" & @CRLF & _
"Donald Ben Ed Jax"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")