$re = '/(?<=potato).{14}/';
$str = 'potato0123456789abcdefgh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);