# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^dr(?!.*(?:last|statement|available)).*\.html$"
test_str = ("/directory/index.html\n"
"/index.html\n"
"#\n"
"/index.html\n"
"/kss_how.html\n"
"dr_info/swearingenlarry.html\n"
"dr_info/swearingenlarrylast.html\n"
"dr_info/kingjohn.html\n"
"dr_info/kingjohnlastzxc.html\n"
"dr_info/_coble.jpg\n"
"dr_info/coblebillielast.html\n"
"dr_info/netherystephen.jpg\n"
"dr_info/netherystephenlast.html\n"
"dr_info/rougeaupaul.jpg\n"
"dr_info/no_last_statement.html\n"
"dr_info/no_info_available.html\n"
"dr_info/no_last_statement.html\n"
"dr_info/no_last_statement.html\n\n"
"drlast")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.