const regex = /(?:^----CAPITAL WORDS:\n|\G)(?!(----(?:MORE )?CAPITAL WORDS:))(\S.*)(?:\n(?!(?1))(\S.*))+\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^----CAPITAL WORDS:\\n|\\G)(?!(----(?:MORE )?CAPITAL WORDS:))(\\S.*)(?:\\n(?!(?1))(\\S.*))+\\s*', 'gm')
const str = `Some random text before.
----CAPITAL WORDS:
first subheading
https://link1
https://link2
second subheading
https://link3
third subheading
https://link4
https://link5
https://link6
https://link7
----MORE CAPITAL WORDS:
Some random text after.
Some random text before.
----CAPITAL WORDS:
first subheading
https://link1
https://link2
----MORE CAPITAL WORDS:
second subheading
https://link3
third subheading
https://link4
https://link5
https://link6
https://link7
----MORE CAPITAL WORDS:
Some random text after.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}