$re = '/([0-9]+)+[^.html]/';
$str = '12321.html
321312.html
321.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);