re = /(https:\/\/www\.|http:\/\/www\.|https:\/\/|http:\/\/)?[a-zA-Z0-9]{2,}(\.[a-zA-Z0-9]{2,})(\.[a-zA-Z0-9]{2,})?/m
str = 'https://www.regex101.com
https://www.reddit.com
www.reddit.com
reddit.com
old.reddit.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end