$re = '/(?<=user=)([^;]+)/m';
$str = 'user=djdjdjjdjdjdj; user=jdjdjdjdjdj;
user=djdjdjjdjdjdj;user=jdjdjdjdjdj;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);