$re = '/(.)((?!\1).)((?!\1|\2).)((?!\1|\2|\3).)/m';
$str = 'mjqjpqmgbljsphdztnvjfqwrcgsmlb';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);