const regex = /^(?=[a-zA-Z0-9`'. -]+$)(?!.*[0-9'` -]{2})[^\r\n.]*(?:\.[ a-z][^\r\n.]*)*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[a-zA-Z0-9`\'. -]+$)(?!.*[0-9\'` -]{2})[^\\r\\n.]*(?:\\.[ a-z][^\\r\\n.]*)*$', 'gmi')
const str = `a1rte
'tyer4
'4rt
this is a test. this is a test
this is a te.st. this is a test
this is a test. this is a test.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}