re = /((?<=[.!?])|(?<=[.!?]\"))[ ]+(?=[A-Z])/m
str = 'Sentence 1 here. This sentence contains 1 fl. oz. but is one sentence.
Sentence 1 here." This sentence contains 1 fl. oz. but is one sentence.
Sentence 1 here... This sentence contains 1 fl. oz. but is one sentence.
"Sentence 1 here.?!?!" This sentence contains 1 fl. oz. but is one sentence.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end