use strict;
my $str = 'abc
foo
';
my $regex = qr/\w+$/p;
my $subst = '#';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";