$re = '/^Test1|[0-9]+$/m';
$str = 'Test1$%^&^%$##
_______________________________-5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);