import Foundation
let pattern = #"(?:.*\v{1,2}){0,5}(.*The Quick Brown Fox Jumps Over the Lazy Dog\.)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Blah blah.
Line 1: This is the first line.
Line 2: This is the second line.
Line 3: This is the third line.
Line 4: This is the fourth line.
Line 5: This is the fifth line.
Line 6: The Quick Brown Fox Jumps Over the Lazy Dog.
Line 7: This is the seventh line.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)