$re = '/(?<=Nome: ).+/m';
$str = 'a1in1iionia
Dados do cliente
Nome: Foo
E-mail: foo@bar.com.br
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);