const regex = /\(\w+;\s+(?<os>\w+)\s+(?<os_version>\w+);.*SamsungBrowser\s+\/\s+\d+\.\d+\s+(?<software>[^\/]+)\/(?<software_version>[^ ]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(\\w+;\\s+(?<os>\\w+)\\s+(?<os_version>\\w+);.*SamsungBrowser\\s+\\\/\\s+\\d+\\.\\d+\\s+(?<software>[^\\\/]+)\\\/(?<software_version>[^ ]+)', 'gm')
const str = `Android user - Mozilla/5.0 (Linux; Android 10; SAMSUNG SMT590) AppleWebKit/537.36 (KHTML, like Gecko) SamsungBrowser / 12.1 Chrome/79.0.3945.136 Safari/537.36`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}