re = /^(.*)\/(?!.*(contact|about|subscribe|favorite)).*$/m
str = '/mrk/not-that
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end