$re = '/.+?\{/m';
$str = '@media screen and (min-width:1280px) {
@media screen and (min-width:1088px) and (max-width:1279px) {';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);