$re = '/(?<=\d)[a-zA-Z]+/m';
$str = 'WRA1007
1085808
1092650S
3901823CV';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);